iChun Util Mod 1.10.2/1.8/1.7.10/1.7.2

iChun Util Mod is a shared library required by a couple of iChun's Mods. Made for Minecraft 1.5 or later.

iChun-Util-Mod.jpg
iChun Util Mod is a shared library required by a couple of iChun’s Mods. Made for Minecraft 1.5 or later.

How to install iChun Util Mod:

  • Download and install Minecraft Forge.
  • Download the mod.
  • Go to %appdata%.
  • Go to .minecraft/mods folder.
  • Drag and drop the downloaded jar (zip) file into it.
  • If one does not exist you can create one.
  • Enjoy the mod.

iChun Util Mod Download Links:

File Name Status Game Version Date
iChunUtil-1.10.2-6.3.2.jar Release 1.10.2 4 hours ago
iChunUtil-4.2.3.jar Release 1.7.10 Oct 21, 2016
iChunUtil-5.5.0.jar Release 1.8 Oct 3, 2015
iChunUtil-3.3.0.jar Release 1.7.2 Mar 31, 2015
iChunUtil2.4.0.zip Release 1.6.4 Mar 31, 2015

Credits: iChun

Related Posts
  • André Birnfeld KoGaMa

    Uol

  • Robert Harshberger

    This mod is out-dated

    • Robert Harshberger

      Full:

    • I updated for 1.8. Thanks

      • Robert Harshberger

        I use 1.7.10

      • Robert Harshberger

        Can you please make a v 4.2.2 mod for mc 1.7.10

  • Boltra

    It won’t work with any of my minecraft versions, and i tried everything i could. Can you please try to release this for any older versions of forge, like 11.14.1.1322 or 10.13.2.1230?