Forever Enough Items Mod 1.11.2/1.10.2/1.9.4/1.8.9

Forever Enough Items Mod is improved from Not Enough Items. This mod is compatible with Minecraft 1.9 and have many new upgrades from the former one.

Forever-Enough-Items-Mod.jpg

Forever Enough Items Mod is improved from Not Enough Items. This mod is compatible with Minecraft 1.9(see also at Minecraft 1.9 Mods) and have many new upgrades from the former one.

Features:

  • Utilities grid on top left.
  • Inventory save and load.
  • Item Subsets.
  • Unlimited amount of profiles.
  • Full configurability: from background color to disabling whole element.
  • API for easier integration.

Screenshot:

Forever-Enough-Items-Mod-1.jpg

Configs:

  • If you hover over anything (from FEI) and hold shift, tooltip explaining how to use it will appear.
  • In the bottom left corner, you have profiles selector. Left clicking will display quick selector, right clicking will bring up profiles manager. In there you can change, remove and create new profiles. From there eveything is annotated and intuitive to use!
  • You can also go to profiles manager anytime (in gui), by hitting P.
  • Concerning elements positions: you can align elements, in “Position And Size” gui, by using your numpad (2 axis), and your arrows (1 axis: x for left & right, y for up & down).

Custom permissions system:

  • FEI has custom permissions system. It consists of user, moderator, administrator and owner. You can use /feiop to OP others. You can OP to any level below yours.
  • In order to OP first player (owner), use server console with /feiop (server), which will make PLAYER and owner, or /feiop (single player / lan), to OP yourself (works only if you’re hosting the world).
  • Each “game changing” action has permission level that user must have. For example: game mode utility or inventory loader. But, displaying chunk edges or saving inventory is not game changing, so you can save your inventory without any permission level.

Just Enough Items (JEI) overriden:

  • FEI overrides some JEI functionality in order to corespond to profile system. For example, (by default), search bar is moved to center. You may also notice that wrench icon in bottom right corner is gone. That’s because JEI is now configured per profile.

How to install:

Forever Enough Items Mod Download Links:

File Name Status Game Version Date
Forever-Enough-Items-1.1.0-beta3-1.11.2 Release 1.11.2 Mar 31, 2017
ForeverEnoughItems-1.0.17.2-1.10.2 Release 1.10.2 Nov 5, 2016
ForeverEnoughItems-1.0.14-1.10 Release 1.10 Jun 28, 2016
ForeverEnoughItems-1.0.13-1.9.4 Release 1.9.4 Jun 27, 2016
ForeverEnoughItems-1.0.10-1.9 Release 1.9 May 15, 2016
ForeverEnoughItems-1.0.10-1.8.9 Release 1.8.9 May 15, 2016

Credits: elix_x

Related Posts
  • mommachaos

    cant seem to make this work…excore is messing it up. any tips?

    • SOMEGUY7893 .

      It needs the 1.5.3 version of Excore. Try looking on other sites, there’s for example a 1.5.3 for 1.8.9 which is the one I needed but the Excore listed here only has the 1.8.9’s version 1.5.1.

  • Urbannnnnnnnnnnnn

    my game crashed when i try to install them.
    Do “excore,JEI,Chunk..,Light level ..” have to be in the mod folder aswell ?

  • Nathan Myer

    I installed all the mods I needed and the game crashed when I opened minecraft. (I’m using 1.9 and used all the 1.9 versions of the mods)

  • Artorias

    Hi. how do you activate cheat mode

  • Artorias

    for 1.10.2

  • Artorias

    cant seem to find utilitie grid help plz

  • I have all the mods and it says it is missing mods.

    • Yassine Slaoui

      me too

  • lucas

    —- Minecraft Crash Report —-

    WARNING: coremods are present:
    CCLCorePlugin (CodeChickenLib-1.10.2-2.2.3.57-universal.jar)
    CCCDeobfPlugin (unknown)
    CodeChickenCorePlugin (CodeChickenCore-1.10.2-2.1.8.79-universal.jar)
    NEICorePlugin (NotEnoughItems-1.10.2-2.1.1.146-universal.jar)
    Contact their authors BEFORE contacting forge

    // Uh… Did I do that?

    Time: 04/09/16 11:55
    Description: Rendering screen

    java.lang.NoClassDefFoundError: bxl
    at net.minecraftforge.fml.common.versioning.Restriction.toStringFriendly(Restriction.java:224)
    at net.minecraftforge.fml.common.versioning.VersionRange.toStringFriendly(VersionRange.java:498)
    at net.minecraftforge.fml.client.GuiModsMissing.func_73863_a(GuiModsMissing.java:106)
    at net.minecraftforge.client.ForgeHooksClient.drawScreen(ForgeHooksClient.java:382)
    at net.minecraft.client.renderer.EntityRenderer.func_181560_a(EntityRenderer.java:1094)
    at net.minecraft.client.Minecraft.func_71411_J(Minecraft.java:1076)
    at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:371)
    at net.minecraft.client.main.Main.main(SourceFile:124)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:483)
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28)

    A detailed walkthrough of the error, its code path and all known details is as follows:
    —————————————————————————————

    — Head —
    Thread: Client thread
    Stacktrace:
    at net.minecraftforge.fml.common.versioning.Restriction.toStringFriendly(Restriction.java:224)
    at net.minecraftforge.fml.common.versioning.VersionRange.toStringFriendly(VersionRange.java:498)
    at net.minecraftforge.fml.client.GuiModsMissing.func_73863_a(GuiModsMissing.java:106)
    at net.minecraftforge.client.ForgeHooksClient.drawScreen(ForgeHooksClient.java:382)

    — Screen render details —
    Details:
    Screen name: net.minecraftforge.fml.client.GuiModsMissing
    Mouse location: Scaled: (167, 176). Absolute: (334, 127)
    Screen size: Scaled: (427, 240). Absolute: (854, 480). Scale factor of 2
    Stacktrace:
    at net.minecraft.client.renderer.EntityRenderer.func_181560_a(EntityRenderer.java:1094)
    at net.minecraft.client.Minecraft.func_71411_J(Minecraft.java:1076)
    at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:371)
    at net.minecraft.client.main.Main.main(SourceFile:124)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:483)
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28)

    — System Details —
    Details:
    Minecraft Version: 1.10.2
    Operating System: Windows 10 (amd64) version 10.0
    Java Version: 1.8.0_25, Oracle Corporation
    Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
    Memory: 202552856 bytes (193 MB) / 438128640 bytes (417 MB) up to 1060372480 bytes (1011 MB)
    JVM Flags: 6 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xmx1G -XX:+UseConcMarkSweepGC -XX:+CMSIncrementalMode -XX:-UseAdaptiveSizePolicy -Xmn128M
    IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
    FML: MCP 9.32 Powered by Forge 12.18.1.2076 5 mods loaded, 5 mods active
    States: ‘U’ = Unloaded ‘L’ = Loaded ‘C’ = Constructed ‘H’ = Pre-initialized ‘I’ = Initialized ‘J’ = Post-initialized ‘A’ = Available ‘D’ = Disabled ‘E’ = Errored
    U mcp{9.19} [Minecraft Coder Pack] (minecraft.jar)
    U FML{8.0.99.99} [Forge Mod Loader] (forge-1.10.2-12.18.1.2076.jar)
    U Forge{12.18.1.2076} [Minecraft Forge] (forge-1.10.2-12.18.1.2076.jar)
    U CodeChickenCore{2.1.8.79} [CodeChicken Core] (minecraft.jar)
    U NotEnoughItems{2.1.1.146} [Not Enough Items] (NotEnoughItems-1.10.2-2.1.1.146-universal.jar)
    Loaded coremods (and transformers):
    CCLCorePlugin (CodeChickenLib-1.10.2-2.2.3.57-universal.jar)
    codechicken.lib.asm.ClassHeirachyManager
    codechicken.lib.asm.RenderHookTransformer
    CCCDeobfPlugin (unknown)

    CodeChickenCorePlugin (CodeChickenCore-1.10.2-2.1.8.79-universal.jar)
    codechicken.core.asm.TweakTransformer
    codechicken.core.asm.DelegatedTransformer
    codechicken.core.asm.DefaultImplementationTransformer
    NEICorePlugin (NotEnoughItems-1.10.2-2.1.1.146-universal.jar)
    codechicken.nei.asm.NEITransformer
    GL info: ‘ Vendor: ‘ATI Technologies Inc.’ Version: ‘4.5.13431 Compatibility Profile Context 16.150.2211.0’ Renderer: ‘AMD Radeon HD 8200 / R3 Series’
    Launched Version: 1.10.2-forge1.10.2-12.18.1.2076
    LWJGL: 2.9.4
    OpenGL: AMD Radeon HD 8200 / R3 Series GL version 4.5.13431 Compatibility Profile Context 16.150.2211.0, ATI Technologies Inc.
    GL Caps: Using GL 1.3 multitexturing.
    Using GL 1.3 texture combiners.
    Using framebuffer objects because OpenGL 3.0 is supported and separate blending is supported.
    Shaders are available because OpenGL 2.1 is supported.
    VBOs are available because OpenGL 1.5 is supported.

    Using VBOs: Yes
    Is Modded: Definitely; Client brand changed to ‘fml,forge’
    Type: Client (map_client.txt)
    Resource Packs:
    Current Language: English (US)
    Profiler Position: N/A (disabled)
    CPU: 4x AMD E2-3800 APU with Radeon(TM) HD Graphics

  • Sparkle★Bubz★Panda

    it keeps crashing

  • A G Gaming

    Why do i have to download 5 things just to be able to use this? Why can’t it work with just forge? Seems like a lot of extra junk just for one mod.